БСП: Дополнительная обработка (Регламенты) + Расширения, примеры от сложного к универсальному

Публикация № 829920

Разработка - Практика программирования

РЗ Регламентное задание БСП Дополнительные обработки Отладка Обработка Расширения Расширение конфигурации 8.3

Продолжение статьи «БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному». Пойдем от финального примера той статьи и сделаем несколько шагов навстречу к универсальному решению.

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Для экспериментов я использовал Платформы 8.3.10.2650 и 8.3.12.1440, конфигурации БСП 2.4.6.56 и 3.0.1.135.

Завершили мы предыдущую часть так -> Два регламента, форма с ручным запуском и сохранение параметров для регламентов.

Как Вы понимаете, с одной стороны удобно добавлять регламентные задания в дополнительную обработку и обновлять ее, с другой стороны, если нам нужно только поправить код, это опять нужно править обработку и ее закидывать в дополнительные отчеты и обработки. Да и добавление новых регламентных заданий несет некий дискомфорт… Давайте попытаемся сделать мир лучше и удобнее!

Содержание:

Задача 1. Частичный перенос функционала в расширение 8.3.10

Задача 2. Используем расширение 8.3.12 по максимуму

Решение от Петра Малыгина

Заключение

Задачи и решения.

Задача 1: Вынести добавление регламентных заданий из обработки в расширение.

Добавляем расширение конфигурации

Добавляем модуль БПСПро_ОбщийМодуль и создаем процедуру ЗаполнитьКоманды (ПараметрыРегистрации) Экспорт

Нарочно оставляем ее пустой, это нужно, чтобы показать еще одну проблему.

Создаем копированием обработку из предыдущей части и в модуле меняем функцию описания:

СведенияОВнешнейОбработке
 
 

Так же меняем у обработки имя(БСППро_Регламены) и синоним(БСППро: Регламенты)

Сохраняем обработку и добавляем ее в нашу конфигурацию для тестов БСП демо.

Теперь в расширение добавим регламенты.

ЗаполнитьКоманды
 
 
Процедура ЗаполнитьКоманды(ПараметрыРегистрации) Экспорт
	//Регламент1
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	//Регламент2
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 2 регламент'");
	НоваяКоманда.Идентификатор = "Задача2Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
		
КонецПроцедуры

 

Заходим в нашу обработку и что мы видим? Регламентов нет. Открываем форму и видим, что список с регламентами работает.

Мы даже вручную его можем выполнить!

На самом деле все очень просто, список в дополнительных обработках обновляется в момент загрузки файла.

Давайте починим этот момент, тем более у нас на вооружении расширение конфигурации.

Находим справочник ДополнительныеОтчетыИОбработки и добавляем ФормуЭлемента в расширение.

Добавляем команду «ОбновитьКомандыПро» на форму

Прописываем действие:

Для БСП младше 3.0.3.XX БПСПро_ОбновитьКомандыПроПосле
 
 
//Обновляем регламентные задания
&НаКлиенте
Процедура БПСПро_ОбновитьКомандыПроПосле(Команда)
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Успех", Ложь);
	ПараметрыРегистрации.Вставить("АдресДанныхОбработки", АдресДанныхОбработки);

	ПараметрыРегистрации.Вставить("ИмяФайла", Объект.ИмяФайла);

	ПараметрыРегистрации.Вставить("ОтключатьПубликацию", Ложь);
	ПараметрыРегистрации.Вставить("ОтключатьКонфликтующие", Ложь);
	ПараметрыРегистрации.Вставить("Конфликтующие", Новый СписокЗначений);
	ПараметрыРегистрации.Вставить("ЭтоОтчет", Ложь);

	ОбновлениеИзФайлаМеханикаНаСервере(ПараметрыРегистрации);

	// Обработка результата работы сервера.
	Если ПараметрыРегистрации.Успех Тогда
		ОповещениеЗаголовок = НСтр("ru = 'Команды обновлены!'");
		ПоказатьОповещениеПользователя(ОповещениеЗаголовок);
		ОбновлениеИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);
	КонецЕсли;
КонецПроцедуры

 

 
 UPD 01.10.2019 Для БСП старше 3.0.3.XX БПСПро_ОбновитьКомандыПроПосле
//Обновляем регламентные задания
&НаКлиенте
Процедура БПСПро_ОбновитьКомандыПроПосле(Команда)
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Успех", Ложь);
	ПараметрыРегистрации.Вставить("АдресДанныхОбработки", АдресДанныхОбработки);

	ПараметрыРегистрации.Вставить("ИмяФайла", Объект.ИмяФайла);

	ПараметрыРегистрации.Вставить("ОтключатьПубликацию", Ложь);
	ПараметрыРегистрации.Вставить("ОтключатьКонфликтующие", Ложь);
	ПараметрыРегистрации.Вставить("Конфликтующие", Новый СписокЗначений);
	ПараметрыРегистрации.Вставить("ЭтоОтчет", Ложь);

	//ОбновлениеИзФайлаМеханикаНаСервере(ПараметрыРегистрации);
	ОбновитьИзФайлаИСообщить(ПараметрыРегистрации);
	
	// Обработка результата работы сервера.
	Если ПараметрыРегистрации.Успех Тогда
		ОповещениеЗаголовок = НСтр("ru = 'Команды обновлены!'");
		ПоказатьОповещениеПользователя(ОповещениеЗаголовок);
		//ОбновлениеИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);
		ОбновитьИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);
	КонецЕсли;
КонецПроцедуры

 

Сразу скажу: Вырезал из типовой все, что понадобится для регламентов, для других типов команд не пробовал обновлять!

Проверяем:

Заполним параметры:

Проверим, работают ли регламенты, заполним время и подождем…

Первая задача выполнена!

Задача 2: Добавить возможность добавления регламентных заданий и возможность редактирования выполняемого кода без входа в конфигуратор (чтобы было максимально просто).

Для решения этой задачи возможностей расширения 8.3.10 будет недостаточно. Все, что нужно нам умеет 8.3.11.

В платформе 8.3.11 реализована возможность добавлять в расширение конфигурации собственные справочники, документы, планы обмена и регистры сведений.

Повторюсь, я считал и считаю 8.3.11, как и 8.3.9 «Мертворожденными» релизами!  Почему?

Потому, что:

1) 8.3.9 Фирма 1С официально перепрыгнула. То есть, шли релизы типовых конфигураций под 8.3.8, а затем сразу 8.3.10.

2) БСП 3.0 уже идет под 8.3.12 и планируемые конфигурации на сентябрь, тоже анонсируются с 8.3.12.

Поэтому данную задачу выполняем под 8.3.12 и БСП 3.0, с заделом на будущее.

Устанавливаем Демо БСП 3.0 и переносим в нее свои наработки.

Сразу скажу, я показываю только вариант, он еще будет далек от совершенства, поэтому прошу не ругать.

По-хорошему для универсального решения (не только для регламентов) нужно создавать справочник Команды с реквизитами и типами, соответствующими таблицы Команды справочника ДополнительныеОтчетыИОбработки.

Но, мы делаем решение по регламентам. Создадим справочник БПСПро_Регламенты.

                -"КлючРЗ" с типом "Строка(256)"

                -"Идентификатор" с типом "Строка(100)"

                -"Активно" с типом "Булево"

Сделаем КлючРЗ - РежимВыбораИзСписка и создадим процедуру с заполнение списка. Я буду считать, что все обработки нужные нам начинаются с «БСППро»

ПриСозданииНаСервере
 
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Запрос = Новый Запрос("ВЫБРАТЬ
	                      |	ДополнительныеОтчетыИОбработки.ИмяОбъекта КАК КлючРЗ
	                      |ИЗ
	                      |	Справочник.ДополнительныеОтчетыИОбработки КАК ДополнительныеОтчетыИОбработки
	                      |ГДЕ
	                      |	НЕ ДополнительныеОтчетыИОбработки.ПометкаУдаления
	                      |	И ДополнительныеОтчетыИОбработки.ИмяОбъекта ПОДОБНО ""БСППро%""");
	
	Элементы.КлючРЗ.СписокВыбора.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("КлючРЗ"));	
КонецПроцедуры

 

Создадим подсистему БПСПро_БСП и поправим модуль БПСПро_ОбщийМодуль (Процедура ЗаполнитьКоманды)

ЗаполнитьКоманды
 
 
Процедура ЗаполнитьКоманды(ПараметрыРегистрации,КлючРЗ) Экспорт
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	БПСПро_Регламенты.Наименование КАК Наименование,
		|	БПСПро_Регламенты.Идентификатор КАК Идентификатор
		|ИЗ
		|	Справочник.БПСПро_Регламенты КАК БПСПро_Регламенты
		|ГДЕ
		|	НЕ БПСПро_Регламенты.ПометкаУдаления
		|	И БПСПро_Регламенты.КлючРЗ = &КлючРЗ
		|	И БПСПро_Регламенты.Активно";
	
	Запрос.УстановитьПараметр("КлючРЗ", КлючРЗ);
	РезультатЗапроса = Запрос.Выполнить();

	//Заполняем команды из справочника регламентов
	Если не РезультатЗапроса.Пустой() Тогда 
		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
			НоваяКоманда.Представление = НСтр("ru = '"+ВыборкаДетальныеЗаписи.Наименование+"'");
			НоваяКоманда.Идентификатор = ВыборкаДетальныеЗаписи.Идентификатор;
			НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
			НоваяКоманда.ПоказыватьОповещение = Истина;
		КонецЦикла;
	КонецЕсли;	
КонецПроцедуры

 

В модуле обработки изменяем функцию СведенияОВнешнейОбработке, меняем одну строчку.

Было: БПСПро_ОбщийМодуль.ЗаполнитьКоманды(ПараметрыРегистрации);

Стало: БПСПро_ОбщийМодуль.ЗаполнитьКоманды(ПараметрыРегистрации,ЭтотОбъект.Метаданные().Имя);

Обновляем и проверяем.

Возможность добавления регламентных заданий без входа в конфигуратор сделана, теперь сделаем возможность добавления кода.

По-хорошему, нужен справочник с Командами и параметрами, но я не ставлю целью сделать продукт для продажи. Моя цель показать сам принцип. Поэтому создаем справочник «БПСПро_КодВыполненияРегламенов»

                -"Идентификатор" с типом "Строка(100)"

                -"ТекстКоманды" с типом "Строка(неограниченной длинны)"

                -"Параметры" таблица значений

                               -"Имя" с типом "Строка(50)" (но лучше создать справочник параметров и использовать ссылку)

                               -"ЗначениеПоУмолчанию" составной тип "Строка, ПеречислениеСсылка.ЦветаЗаметок"(для нашего примера)

Правим справочник «БПСПро_Регламенты», добавляем реквизит КодВыполнения с типом "СправочникСсылка.БПСПро_КодВыполненияРегламенов" и табличную часть Параметры.

При изменении «Код выполнения» выполняем следующий код:

КодВыполненияПриИзменении
 
 
&НаКлиенте
Процедура КодВыполненияПриИзменении(Элемент)
	КодВыполненияПриИзмененииНаСервере();
КонецПроцедуры
&НаСервере
Процедура КодВыполненияПриИзмененииНаСервере()
	//Чистим если надо
	Если Объект.Параметры.Количество() > 0 Тогда 
		Объект.Параметры.Очистить();
	КонецЕсли;

	Если ЗначениеЗаполнено(Объект.КодВыполнения) Тогда 
		//Заполняем значениями по умолчанию		
		Для Каждого строкаПараметры из Объект.КодВыполнения.Параметры Цикл 
			новыйПараметр = Объект.Параметры.Добавить();	
			новыйПараметр.Имя = строкаПараметры.Имя;
			новыйПараметр.Значение = строкаПараметры.ЗначениеПоУмолчанию;
		КонецЦикла;		
	КонецЕсли;		
КонецПроцедуры

 

В модуль БПСПро_ОбщийМодуль добавляем процедуру ВыполнитьКомандуРЗ

ВыполнитьКомандуРЗ
 
 
Процедура ВыполнитьКомандуРЗ(ПараметрыВыполнения) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	БПСПро_Регламенты.Ссылка КАК Ссылка,
		|	БПСПро_Регламенты.КодВыполнения КАК КодВыполнения
		|ИЗ
		|	Справочник.БПСПро_Регламенты КАК БПСПро_Регламенты
		|ГДЕ
		|	НЕ БПСПро_Регламенты.ПометкаУдаления
		|	И БПСПро_Регламенты.КлючРЗ = &КлючРЗ
		|	И БПСПро_Регламенты.Активно
		|	И БПСПро_Регламенты.Идентификатор = &Идентификатор";
	
	Запрос.УстановитьПараметр("КлючРЗ", ПараметрыВыполнения.КлючРЗ);
	Запрос.УстановитьПараметр("Идентификатор", ПараметрыВыполнения.Идентификатор);

	РезультатЗапроса = Запрос.Выполнить();
	
	//Заполняем параметры и выполняем команду
	Если не РезультатЗапроса.Пустой() Тогда 

		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		
		Если ВыборкаДетальныеЗаписи.Следующий() Тогда 
			
			//Параметры заполнения
			ПараметрыРЗ = Новый Структура;
			Для Каждого СтрокаПараметровПоУмолчанию из ВыборкаДетальныеЗаписи.КодВыполнения.Параметры Цикл 
				
				ПараметрыОтбора = Новый Структура;
				ПараметрыОтбора.Вставить("Имя", СтрокаПараметровПоУмолчанию.Имя);
				НайденныеСтроки = ВыборкаДетальныеЗаписи.Ссылка.Параметры.НайтиСтроки(ПараметрыОтбора);
				Если НайденныеСтроки.Количество() = 0 Тогда 
					ПараметрыРЗ.Вставить(СтрокаПараметровПоУмолчанию.Имя, СтрокаПараметровПоУмолчанию.ЗначениеПоУмолчанию);	
				Иначе
					ПараметрыРЗ.Вставить(СтрокаПараметровПоУмолчанию.Имя, НайденныеСтроки[0].Значение);		
				КонецЕсли;
				
			КонецЦикла;	
	        ПараметрыВыполнения.Вставить("ПараметрыРЗ",ПараметрыРЗ);
			
			//Выполняем команду по регламенту
			Попытка
				Выполнить(ВыборкаДетальныеЗаписи.КодВыполнения.ТекстКоманды);
			Исключение
				//СообщениеОбОшибке = ОписаниеОшибки();
			КонецПопытки;	
		КонецЕсли;
	
	КонецЕсли;
КонецПроцедуры

 

В модуле обработки правим ВыполнитьКоманду. По идее можно оставить только ВыполнитьКоманду и СведенияОВнешнейОбработке остальное можно удалить.

ВыполнитьКоманду
 
 

Из формы обработки убираем все лишнее:

Код модуля формы:
 
 

Теперь нам нужно сохранить все изменения и в клиентской части заполнить текст команды, параметры, обновить обработку и назначить время для РЗ.

Создаем новый элемент справочника «Код выполнения регламентов (БСППро)»

Текст команды забираем тот, что был написан в 3 задании предыдущей статьи (Процедура СоздатьНовыйЭлементСправочникаЗаметки)

Текст команды
 
 
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	
	//Обрабатываем Параметры
	перТекстСодержания = "Заметка создана ";
	перПометка = Перечисления.ЦветаЗаметок.Красный;
	Если ПараметрыВыполнения.Свойство("ПараметрыРЗ") Тогда 
		Если ТипЗнч(ПараметрыВыполнения.ПараметрыРЗ) = Тип("Структура") Тогда 
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("ТекстСодержания") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания) Тогда 
					перТекстСодержания = ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания;	
				КонецЕсли;	
			КонецЕсли;
			
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("Пометка") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.Пометка) Тогда 
					перПометка = ПараметрыВыполнения.ПараметрыРЗ.Пометка;	
				КонецЕсли;	
			КонецЕсли;

		КонецЕсли;	
	КонецЕсли;
	
	//Добавили проверку регламент\форма	
	ФорматированныйТекст.Добавить(перТекстСодержания + ?(ПараметрыВыполнения.ВидЗапускаРегламент,"регламентом","вручную") + " в "+Строка(ДатаТекСеанса), Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;

	ТекущийОбъект.Пометка 			= перПометка;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();

 

Добавляем параметры:

Теперь отредактируем ранее созданные регламенты. Выберем в них данную команду и заполним параметры.

Записываем и заменяем предыдущую дополнительную обработку на эту.

Проверяем ручной запуск и регламеты:

Вторая задача выполнена!

Хочу еще упомянуть решение Петра Малыгина

В данный момент у него есть практически готовое решение по автоматизации в части Выполнения кода. С его решением можно сделать универсальный (или почти универсальный) регламент.

Кому интересно, можно ознакомиться с видео его решения:

Описание решения

Пример решения

Ссылка на статью Петра Малыгина

Заключение:

В первой части мы рассмотрели, как сделать сложные регламенты без доработки конфигурации, но, как вы понимаете, есть свои неудобства с обновлением регламентов.

Во второй части мы сделали решение, позволяющее в будущем создавать регламенты без доработки конфигурации и без изменений в конфигураторе.

Старался расписаться максимально доступно и примеры выбрал не «Hello, world!».

Надеюсь, статьи будут вам полезны (не забывайте нажимать на звездочку), удачи в работе!

Скачать файлы

Наименование Файл Версия Размер
БСП: Дополнительная обработка + Расширение (под 8.3.12)
.zip 90,42Kb
01.10.19
12
.zip 1.0.0.2 90,42Kb 12 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. pm74 167 22.05.18 08:02 Сейчас в теме
(0) Приветствую.
Правильно ли я понял чтобы добавить новое РЗ нужно заново регистрировать обработку " БСППро: Регламенты " ?
2. dsdred 1406 22.05.18 08:28 Сейчас в теме
(1)Доброе утро.
Нужно обновить добавленную обработку.
В типовом решении БСП, нужно "Обновлять из файла" с последующем выбором обработки.
В моем решении по нажатию кнопки "Обновить команды"
3. pm74 167 22.05.18 08:30 Сейчас в теме
(2) старые расписания не слетают при обновлении ?
4. dsdred 1406 22.05.18 08:31 Сейчас в теме
(3)Тестировал, не слетали.
5. pm74 167 22.05.18 08:32 Сейчас в теме
(4) ок , я сделал расширение для 8.3.11 нужно только привязать к обновлению регламента
выложу в ближайшее время
6. dsdred 1406 22.05.18 08:39 Сейчас в теме
(5)Хорошая новость! Добавте ссылку в Коментарии, я прямо в статью ее вставлю.
Прилагаю Пруф по регламентам
Прикрепленные файлы:
7. Бубузяка 62 23.05.18 09:24 Сейчас в теме
Спасибо, Дмитрий. На мой взгляд - это очень хорошая идея популяризация БСП.
8. dsdred 1406 23.05.18 10:55 Сейчас в теме
(7)Спасибо за отзыв.
На самом деле моя цель обширнее, эти статьи лишь начало.

Я хочу зайти через год на ИС и в заголовках больше не видеть или почти не видеть таких слов как COM, XML...
Хочу видеть HTTP, JSON.

Возможно у людей просто нет времени это изучить и статьи с картинками и описанием поменяют эту ситуацию.
Возможно через 2 года 1с программист прекратит быть ругательством среди других программистов.

Хотя конечно возможно это все утопия.
9. kadild 23.05.18 22:50 Сейчас в теме
(8) Ну рассмешили.
COM не только связь с Office. но и у другие приложения. например Adobe, imagemagick и тп.
XML - язык разметки (читаемость, описание типов, схемы и тп), а не формат данных JSON.
Откройте для себя XML Schema.

не видеть таких слов как COM, XML...
Хочу видеть HTTP, JSON.

Возможно через 2 года 1с программист прекратит быть ругательством среди других
Из-за таких рассуждений и ржут над однэссниками.
11. dsdred 1406 24.05.18 07:19 Сейчас в теме
(9)Я рад что Вас рассмешил, смех продлевает жизнь.
Я как всегда хотел написать коротко, но...
Не имею против
например Adobe, imagemagick и тп
и даже про контекст 7.7 или 6...
Имел ввиду обмен между базами 8 и предоставления данных например веберу.

Мне лично не до смеха. Загляните на закладку Библиотека и Вам даже долго искать не придется там свежий пример майская статья этого года ссылающаяся на статью 12 года одного и того же автора.

Я очень благодарен одному грамотному руководителю который 4 с небольшим года назад на тривиальную задачку, которую я сделал бы через com сказал: -Мне тут наш московский программист сказал что web сервисы быстрее, не посмотрите?
Помню как первый раз ставил апачи и пробывал, пробывал. Помню как ему демонстрировал работу и он сказал: -УЖЕ?
Затем HTTP сервисы, битва с объемом передоваемых данных и т.д.
Вот что я имел ввиду.
12. pm74 167 27.05.18 23:42 Сейчас в теме
(0) обновил публикацию , отправил модераторам https://infostart.ru/public/728511/ ,
13. dsdred 1406 28.05.18 07:38 Сейчас в теме
(12)Ссылку на статью добавил в статью.
14. pm74 167 28.05.18 09:10 Сейчас в теме
(13) появилось в общем доступе
15. vladpisklov 30.09.19 23:48 Сейчас в теме
Не подскажите что за процедура:

ОбновлениеИзФайлаМеханикаНаСервере(ПараметрыРегистрации);

а так-же:
ОбновлениеИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);

При подключении расширения к базе ругается на эти процедуры.
16. dsdred 1406 01.10.19 00:10 Сейчас в теме
(15)Это процедуры на форме элемента справочника дополнительные обработки. Служат для обновления команд.

Подскажите какую версию БСП используете? Я себе установлю и посмотрю, что там изменилось на форме элемента справочника доп обработок.
17. vladpisklov 01.10.19 06:41 Сейчас в теме
18. dsdred 1406 01.10.19 10:17 Сейчас в теме
(17)Да, действительно обновилось в БСП название процедур.
Напишите мне в личку Ваш имейл я вам скину обновленное расширение.

И в статье сейчас UPD сделаю
Оставьте свое сообщение

См. также

Обмен каталогом товаров между 1С и другими системами в формате YML (Yandex Market Language) Промо

Обмен через XML WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 УНФ УТ11 Платные (руб)

Обработка для выгрузки/загрузки каталога номенклатуры в 1С из формата YML (Yandex Market Format). В настоящий момент поддерживается выгрузка в YML из УТ11 и УТ10. Загрузки из YML в УТ11, УТ10 и УНФ 1.6. Обработки тестировалась на конфигурациях УТ 11.3.1.115 (управляемые формы), УНФ 1.6.9.36 (управляемые формы) и УТ 10.3.32.2 (обычные формы). Обращайтесь по вопросом адаптации обработки под другие конфигурации. Обработка предоставляется с открытым кодом. Кроме того, будет осуществляться развитие проекта. Выпускаемые обновления будут распространяться среди покупателей БЕСПЛАТНО в течение 1 года с момента покупки. Обратите внимание, что при чтении YML-файлов большого размера может происходить увеличение размера временных файлов 1С. Поэтому для быстрого чтения объемных файлов необходимо иметь соответствующей мощности ПК. Если есть потребность быстро загружать объемные файл рекомендуется использовать сервера, а не обычные ПК.

4900 руб.

18.05.2015    62896    108    48    

5 причин 1С-нику участвовать в хакатонах

Личная эффективность Бесплатно (free)

5 причин, зачем вам ходить на хакатоны, почему на это стоит выделять время.

24.05.2020    3685    0    comol    19    

Перенос данных из УНФ 1.6 в БП 3.0

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УНФ БП3.0 Россия БУ УУ Платные (руб)

Обработка для переноса документов, начальных остатков и справочной информации. Можно использовать как для разового начального переноса данных, так и для организации регулярного обмена данными. Есть возможность указать период отбора данных и установить фильтр по организациям. Перенос оперативно обновляем при выходе новых релизов программ 1С. По возникающим вопросам оказываем техническую поддержку (через тикеты на Инфостарте).

15000 руб.

18.05.2020    789    0    0    

Перенос данных из ERP 2 / КА 2 / УТ 11 в УНФ 1.6

Обмен данными 1С Перенос данных из 1C8 в 1C8 v8 УНФ ERP2 УТ11 КА2 Россия Платные (руб)

Обработка позволяет выполнить полный перенос данных из программ 1С:ERP / КА 2 / УТ 11 в программу 1С:УНФ. Переносятся начальные остатки на выбранную дату, документы за период, а также справочная информация. Переносятся все возможные виды документов. Оказываем техническую поддержку. Оперативно обновляем правила конвертации данных при выходе новых релизов программ 1С.

15000 руб.

28.04.2020    1096    0    2    

Распознавание документов в "1С:Предприятие 8.3": расширение для типовых конфигураций. Промо

Обработка справочников Внешние источники данных Управление персоналом (HRM) Управление персоналом (HRM) v8 1cv8.cf Платные (руб)

Расширение для типовых конфигурация и для самостоятельной интеграции системы распознавания документо удостоверяющих личность и прочих документов непосредственно из информационных баз "1С:Предприятия 8.3". Расширение позволит не изменять типовой код конфигурации, расширить текущий функционал несколькими кликами мыши.

5000 руб.

26.01.2016    46603    59    0    

Автозагрузка банковских выписок (БП 3.0)

Банковские операции Обмен с банком v8 v8::БУ БП3.0 БУ Абонемент ($m)

Расширение позволяет автоматизировать загрузку банковских выписок в программу 1С:Бухгалтерия предприятия, ред. 3.0. При начальной настройке создается регламентное задание. Период срабатывания регламентного задания в дальнейшем можно поменять в консоли заданий. Требуется указать каталог, из которого нужно загружать банковские выписки.

1 стартмани

06.04.2020    1964    3    primat    3    

Как я собрал для себя высокопроизводительный и бесплатный облачный бекенд для 1С на PosgreSQL + PostgREST

Производительность и оптимизация (HighLoad) WEB Интеграция Мобильная разработка Администрирование веб-серверов v8 Бесплатно (free)

В этой статье я расскажу о проблемах бека для мобильных приложений или другого фронта, который требует производительности, быстрой реакции и отказоустойчивости, и как я решил это благодаря opensource проекту PostgREST и СУБД Postgre SQL 12. Проведу простой тест производительности для сравнения 1С с данным решением. Это может быть полезно всем, кто разрабатывает мобильные приложения либо фронтсайд-приложения для 1С на чем угодно - на мобильной платформе или на нативном языке или на Simple UI. И также обзор новых функций SimpleUI для связи с этим бекендом.

31.03.2020    9685    0    informa1555    21    

Печать текстовых водяных знаков в файлы PDF из 1С

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Обработка для группового наложения текстовых водяных знаков в документах PDF с помощью бесплатной программы AVS Document Converter. Тестировалась в ОС Windows 7 64 bit на платформе 8.3.15.1830 с AVS Document Converter 4.2.3.268.

2 стартмани

13.03.2020    866    3    Spartan    8    

АСТ: Обмен с ЕГАИС из 1С Промо

Внешние источники данных Обработка справочников Обработка документов Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ ERP2 БП1.6 БП3.0 УТ11 КА2 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Пищевая промышленность Россия БУ УУ Акцизы Платные (руб)

Автоматический обмен данными с системой ЕГАИС из 1С: загрузка данных по контрагентам, производителям, алкогольной продукции, сопоставление данных и запись их в базу данных; загрузка ТТН и справок Б от поставщиков, отправка по ним актов; выгрузка ТТН покупателям; запрос остатков. Выгрузка производства, импорта, работа с торговым залом, помарочный учет. Запрос остатков и движения по справке Б, работа с марками и штрихкодами продукции. Запрос статуса ТТН, необработанных ТТН, отправка данных АСИиУ. Работа с актами расхождений и запросами на отмену актов.

4000 руб.

30.09.2015    271132    652    790    

Полиграфистки сходят с ума по одной

О жизни Бесплатно (free)

Мой опыт прохождения полиграфа.

06.03.2020    4552    0    1c-intelligence    78    

Перенос документов, остатков и справочников из УНФ 1.6 в УТ 11 / КА 2 / ERP 2 (ЕРП 2)

Обмен данными 1С Обмен через XML Перенос данных из 1C8 в 1C8 v8 УНФ ERP2 УТ11 КА2 Россия Платные (руб)

Правила переноса данных из УНФ в УТ 11 / КА 2 / ERP 2 (ЕРП 2) позволяют перенести начальные остатки на выбранную дату, а также документы за период, начиная с этой даты. Это позволит комфортно начать ведение учета в новой программе 1С. Предоставляем техническую поддержку, оперативно обновляем перенос при выходе новых релизов программ 1С. Добавляем новые виды объектов в переноса по просьбам наших клиентов.

12125 руб.

05.12.2019    4268    4    7    

Универсальное выборочное удаление данных из базы 1С (любые конфигурации на упр.формах: БП 3.0, УТ 11, КА 2, ERP, УНФ, ЗУП 3, Розница и т.д.)

Чистка базы Универсальные обработки v8 v8::УФ Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Платные (руб)

Обработка позволяет удобно выборочно удалить данные из базы 1С. Это могут быть как неиспользуемые элементы справочников, так и неактуальные организации. При этом есть возможность провести анализ пересечений документов с другими организациями и таким образом уберечься от того, что при удалении обороты по другой организации изменятся.

3000 руб.

28.11.2019    3674    10    7    

Скачивание котировок акций и фьючерсов с сайта "Финам" Промо

Универсальные обработки WEB Финансовые услуги, инвестиции УУ Платные (руб)

Скачивание котировок акций и фьючерсов с сайта "Финам" с удобными настройками и отборами. Можно выбрать любой, даже самый большой период времени. Есть возможность сохранения в отдельные файлы данных по ценам за каждый день.

4950 руб.

07.10.2015    18514    1    4    

Стабильность превыше всего

Рефакторинг и качество кода v8 Бесплатно (free)

Странная заметка о поддержании стабильности в условиях интенсивного изменения конфигурации.

07.11.2019    8642    0    YPermitin    40    

6 шотов

О жизни Бесплатно (free)

Небольшие пятничные истории о взаимоотношениях в коллективе

01.11.2019    9187    0    sapervodichka    28    

Шорты Белокаменцева

О жизни Бесплатно (free)

Короткие версии старых статей

28.10.2019    7323    0    1c-intelligence    18    

Конфигурация "Весовая" ред. 3.0 для Платформы 8.3 Промо

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Управленческий учет (прочее) v8 Транспорт, автопарки, такси Беларусь Украина Россия Казахстан УУ Платные (руб)

Конфигурация "Весовая" ред. 3.0 для "1С:Предприятие 8.3" - это решение для организации контроля движения грузов через весовую и остатков на складах предприятий, занимающихся: - сельскохозяйственной деятельностью; - тепличных комплексов; - добывающей и горнодобывающей деятельностью; - производителей бетона и асфальта; - дорожно ремонтно-строительных управлений; - торговых организаций; - речных и морских портов осуществляющих перевалку груза; - и организаций, использующих весовую. Конфигурация реализована полностью в интерфейсе "Такси".

3000 руб.

24.03.2015    67730    85    59    

Перенос данных из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0 (правила переноса остатков, документов и справочников из УТ 10.3 в БП 3.0)

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ УУ Платные (руб)

Правила переноса остатков, документов и справочников из УТ 10.в БП 3.0 позволяют как начать вести учет в новой базе БП 3.0, так и организовать регулярный обмен данными, вводимыми на стороне УТ 10.3. Перенос оперативно обновляем на новый релизы, предоставляем техническую поддержку. Возможно бесплатное выполнение тестового переноса данных перед приобретением нашей разработки.

10000 руб.

02.10.2019    4538    2    8    

Видя деньги

О жизни Бесплатно (free)

Немножко бизнес-программирования.

09.09.2019    7567    0    1c-intelligence    94    

Куда и как расти

Личная эффективность Бесплатно (free)

Даже если сейчас у вас стабильная работа, это не означает, что завтра ситуация не изменится, вы не окажетесь на рынке труда в поисках новой должности. Какие специалисты сейчас требуются, и какие тренды превалируют на рынке IT и в сфере 1С, на конференции рассказал директор по развитию внедренческого центра «Раздолье» Андрей Мироненко. Он работает в качестве руководителя IT-направления свыше 15 лет, а в должности директора IT – 10 лет. Является автором различных обзоров, курсов и иных полезных материалов. Занимался подбором и мотивацией персонала, разработкой стандартов качества IT-сервисов, руководством проектами автоматизации (ERP, WMS и пр), имеет опыт организации розничных сетей, call-центров, запуска и сопровождения интернет-магазинов.

16.05.2019    10964    0    andironenko    26    

Adaptersoft : Управление Сбором Данных. Получение сводной отчетности в базе 1С из однотипных файлов Excel Промо

Загрузка и выгрузка в Excel Управление холдингом (CPM) Управление холдингом (CPM) v8 УУ Платные (руб)

Управление Сбором Данных — конфигурация на 1С 8.2 для получения сводной отчетности в базе 1С из однотипных файлов Excel. Отлично подходит для организации оперативного или управленческого учета. Сочетает в себе гибкость ms Excel с защищенностью данных в 1С. Простая, понятная и доступная система в отличие от 1С:Консолидации или 1С:Свод отчетов.

15000 руб.

25.09.2014    19914    2    8    

Универсальный HTTP-сервис на платформе 1С, аля HTTP-сервер с примером

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Практический кейс построения HTTP-сервиса, который работает по принципу HTTP-сервера, с разбором всех методов построения и разработки класса задач построения личных кабинетов и сопряжения их с центральной базой.

1 стартмани

13.05.2019    25514    115    Diversus    42    

Удаленная работа. Как выбрать работодателя

Личная эффективность Бесплатно (free)

На что обратить внимание при выборе удаленного работодателя

15.11.2018    11328    0    sergey_garin    24    

В гости к отцу

О жизни Бесплатно (free)

Про старых и новых инженеров.

14.11.2018    7253    0    1c-intelligence    34    

Перенос данных из БП 3.0 в УПП 1.3 Промо

Обмен данными 1С Обмен через XML Перенос данных из 1C8 в 1C8 v8 УПП1 БП3.0 Россия Платные (руб)

Поддерживается перенос документов и справочной информации. Есть возможность указать период отбора данных и установить фильтр по организациям. Перенос оперативно обновляем при выходе новых релизов программ 1С. По возникающим вопросам оказываем техническую поддержку (через тикеты на Инфостарте).

12125 руб.

06.05.2020    1105    1    1    

Контроль отрицательных остатков в конфигурациях: УТ 11.4, КА 2.4, ЕРП 2.4

Бухгалтерский учет Учет ТМЦ Управленческий учет (прочее) Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Подробный разбор всех присутствующих в конфигурациях УТ 11, КА 2, ЕРП 2 вариантов контроля отрицательных остатков: по организациям, складам, оперативный контроль

08.11.2018    46324    0    ids79    73    

О главном инструменте разработчика, аналитика и руководителя

Личная эффективность Бесплатно (free)

Думаю, все были на собеседованиях и на вопрос «какие инструменты вы используете в работе», у всех заготовлен ответ про языки, библиотеки, среды разработки, базы данных и т.д. и т.п. В крайнем случае, у кого-то может быть припасена шутка про грабли и напильник. Ну и все доблестно перечисляют всякие XDTO и СКД, думая, что перечисляют невероятно важные средства разработки, в которых хорошо разбираются. Но правда заключается в том, что единственно важным средством разработки является ваш мозг. И вы абсолютно ничего не знаете о том, как он устроен.

10.08.2018    10594    0    m-rv    40    

Способы оптимизации переносов данных

Перенос данных из 1C8 в 1C8 Интеграция v8 КД Абонемент ($m)

Хочу рассказать вам про способы оптимизации разработки правил обмена в программе «Конвертация данных» второй редакции. Казалось бы, про эту программу и разработку в ней правил конвертации уже сказано все, что можно. Появились уже более современные и быстрые технологии. Почему же все еще она? Дело в том, что «Конвертация данных» второй редакции все еще актуальна для огромного круга задач. Она имеет очень широкую функциональность и позволяет реализовывать сложные алгоритмы. Годы идут, а люди продолжают ей пользоваться и у них возникает много вопросов по этой программе. Возможно, в будущем вы тоже будете заниматься такими проектами и столкнетесь с задачами, похожими на те, про которые я собираюсь рассказать. Мне хочется вам в этом помочь.

1 стартмани

02.08.2018    15660    11    primat    7    

Перенос данных из КА 1.1 в КА 2 / УТ 11 Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 КА1 УТ11 КА2 Платные (руб)

Комплексную автоматизацию для ведения учета обычно выбирают компании среднего и крупного размера, которые не хотят связываться с обменами. При этом в одной программе необходим функционал бухгалтерии, зарплаты и торговли. Комплексная автоматизация 2 решает эту задачу и содержит самые современные разработки фирмы 1С. Программа хорошо отлажена и проверена на учете реальных организаций, потому что разработана на основе проверенных временем УТ 11 и ERP 2. Типовая обработка перехода с Комплексной автоматизации редакции 1.1 на Комплексную автоматизацию редакции 2 не переносит документы. Для переноса документов, начальных остатков и справочной информации можете воспользоваться предлагаемой разработкой (правила конвертации данных из КА 1.1 в КА 2 / УТ 11). При покупке предоставляю поддержку, оперативно исправляю ошибки, рассылаю обновления при выходе новых релизов.

37125 руб.

04.12.2015    130341    349    286    

Минимализмы 3

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    43884    0    ildarovich    45    

А чё это вы здесь делаете, а?

WEB v8 1cv8.cf Абонемент ($m)

Разработчикам тиражных обработок близка и понятна проблема обратной связи с пользователем. Много важного и полезного можно почерпнуть, зная, что делает бухгалтер, который запустил обработку. В большом мире вэба сбор статистики на сайте дело привычное и даже обязательное. Эта статья покажет практику применения инструментов сбора статистики из мира веба для обработок на платформе 1С:Предприятие.

1 стартмани

21.01.2018    22246    30    infosoft-v    42    

Одно Кольцо, Чтобы Править Всеми

Личная эффективность Бесплатно (free)

Рассказ о внедрении 1С. Необычный.

25.12.2017    14853    0    1c-intelligence    62    

DT:Менеджер 8.2 (8.3) (Распаковка/упаковка *.DT файлов. Быстрый экспорт CF. Сброс пользователей. Работа с "битыми" DT) Промо

Сервисные утилиты Инструментарий разработчика Администрирование данных 1С v8 1cv8.cf Платные (руб)

Внешнее приложение для работы с форматом *.DT. Осуществляет быстрый экспорт конфигурации, очистку сведений о пользователях и может работать с аварийными DT файлами.

6000 руб.

19.04.2013    122356    200    215    

Джеб Кличко

Личная эффективность Бесплатно (free)

Бывает же такое: 1Сник может учиться у Кличко

18.12.2017    16094    0    1c-intelligence    63    

Латентные паразиты

Управление бизнес-процессами (BPM) Бесплатно (free)

Вот вы сидите, и не думаете о паразитах. А они рядом.

04.12.2017    25524    0    1c-intelligence    144    

Комплект увольнения

О жизни Бесплатно (free)

Это все, что останется после меня. Это все, что возьму я с собой.

28.11.2017    26519    0    1c-intelligence    87    

Алкогольная декларация для 1С 8.2, 8.3 (3, 4, 5, 6, 7, 8, 10, 11, 12 формы) УТ11, БП3.0, БП КОРП 3.0, Розница 2, с подписью и шифрованием, Управляемые формы Промо

Регламентированная отчетность Статистики Бухгалтерские Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 v8::УФ Розница БП3.0 УТ11 Россия БУ УУ Акцизы Платные (руб)

Не успеваете сдать декларацию вовремя? Устали заносить/править данные вручную? Давит угроза штрафа в десятки, а то и сотни тысяч? Бессонные ночи и потраченные на работе вечера в пик сдачи отчетности? Вам знакомы эти проблемы? Если да, то у нас есть РЕШЕНИЕ, которое Вам необходимо! Автоматическое заполнение алкогольных деклараций по формам 3 (производство), 4 (использование), 5, 6, 7 (опт), 8 (перевозка), 11, 12 (розница, разделы I и II) по данным учета, проверка и шифрование, а также загрузка из внешних файлов и выгрузка в формате XML 4.30 согласно приказу Росалкогольрегулирования №198 от 05.08.2013 г.

20000 руб.

01.07.2013    89878    72    83    

Суррогаты

О жизни Бесплатно (free)

Статья о том, что вы и без меня прекрасно знаете. Но я напомню.

21.11.2017    28373    0    1c-intelligence    197    

Простой способ повысить шансы на победу, переговоры без поражения. Тонкое искусство переговоров для специалистов по 1С и не только. Часть 2

Личная эффективность Бесплатно (free)

После своей предыдущей публикации https://infostart.ru/public/690718/ получил много сообщений с вопросами. Один из наиболее часто повторяющихся – о том, как повысить шансы на победу в сложных переговорах, если этому никогда не учился? Конечно, от это вопроса веет верой в Гарри Поттера и его волшебную палочку, но мы точно знаем, что правильный ответ есть. Используйте принцип «всегда вдвоем». Это одна из самых простых и самых сильных манипуляций в переговорах.

07.11.2017    10212    0    user809424    17    

Кошка сдохла, хвост облез

Личная эффективность Бесплатно (free)

Практический прием для руководителя из арсенала системного мышления.

04.11.2017    17319    0    1c-intelligence    44    

Подсистема "Инструменты разработчика" v5.35 Промо

Инструментарий разработчика v8 1cv8.cf Бесплатно (free)

Интегрированный набор инструментов разработчика: - консоль кода - консоль запросов - консоль построителя отчетов - консоль компоновки данных - консоль заданий - конструктор запроса - справочник алгоритмов - исследователь объектов - интерфейсная панель - настройка журнала регистрации - анализ журнала регистрации - настройка техножурнала - анализ техножурнала - подбор и обработка объектов - редактор объекта БД - редактор констант - редактор параметров сеанса - редактор изменений по плану обмена - редактор пользователей - редактор предопределенных - редактор хранилищ настроек - динамический список - поиск дублей и замена ссылок - контекстная подсказка - синтакс-помощник - поиск битых ссылок - поиск ссылок на объект - структура хранения БД - удаление объектов с контролем ссылок - и прочее

23.09.2007    476164    4340    tormozit    2665    

Экзорцизм программистскими методами

О жизни Бесплатно (free)

Примеры из жизни о том, как инструменты на платформе 1С помогают компании изгонять зло.

24.08.2017    33044    0    1c-intelligence    59    

Рассылка СМС-сообщений через сервис SMS.ru

SMS рассылки v8 1cv8.cf Россия Абонемент ($m)

Простая конфигурация, позволяющая быстро организовать смс-рассылку через интернет-сервис SMS.ru. Конфигурация собрана на платформе 1С:Предприятие 8.3 (8.3.8.2088), механизм взаимодействия с внешним сервисом - http запросы.

1 стартмани

20.08.2017    11187    43    sdn-1    0    

Агрессия в переговорах

Личная эффективность Бесплатно (free)

Многие люди сравнивают агрессию с отсутствием такта и невоспитанностью либо с плохим настроением. И мало кто задумывается, что она может стать помощником, особенно когда идет речь о сотрудничестве или переговорах с партнерами. Чем может быть полезна агрессия и как правильно ею пользоваться, рассказывает бизнес-тренер, руководитель Петербургской школы переговорщиков «ШИП» Дмитрий Коткин.

08.08.2017    12166    0    user809424    45    

Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо

Администрирование данных 1С Мобильная разработка v8 Бесплатно (free)

Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.

14.04.2017    57871    0    user700211_a.straltsou    27    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    20695    20    sasha777666    62    

Как я стал одинэсником и переехал из провинции в Москву

О жизни Россия Бесплатно (free)

История покорения Москвы.

29.07.2017    16629    0    DmitryKSL    132    

Применение Agile-технологий в проектах 1С

Управление проектом Бесплатно (free)

Agile – это одна из методик ведения проектов. О ее практическом применении в проектах 1С пойдет речь в статье.

25.07.2017    17151    0    kondrat230386    35    

[Простые маршруты]. Работа с картой. Геозоны. Расчет оптимальных вариантов доставки Промо

Рабочее место Универсальные обработки Оптовая торговля Оптовая торговля v8 1cv8.cf Оптовая торговля, дистрибуция, логистика УУ Платные (руб)

Универсальное решение для любых конфигураций по отображению на карте адреса доставки из любых документов базы данных. Интерактивная работа с картой из 1С и обратно. Широкий набор средств для формирования маршрутов на карте вручную. Ключевая особенность программы – умение математически точными методами автоматически рассчитать и представить на карте разные варианты оптимальных маршрутов: - исходя из заданного количества единиц автотранспорта; - исходя из заданной величины максимальной грузоподъемности автотранспорта.

10000 руб.

08.02.2016    51449    29    1    

Установка подключения к MySQL через ODBC connector

Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Руководство, облегчающее жизнь при очередной настройке подключения MySQL к 1С через ODBC connector (driver). Оставлю это хотя бы для себя на память :)

1 стартмани

21.07.2017    19282    5    primara    2    

Как создать коммерчески успешное отраслевое решение

Управление проектом Бесплатно (free)

Есть много информации о том, как сделать конфигурацию, как разработать продукт, чем конфигурация отличается от продукта. Но как создать успешное решение, успешный продукт? Ответ на этот вопрос предложен в статье.

06.07.2017    13292    0    kuld    33    

Планы запросов - это просто!

Производительность и оптимизация (HighLoad) v8::Запросы Бесплатно (free)

Наверное, каждый 1С-ник задавался вопросом "что быстрее, соединение или условие в ГДЕ?" или, например, "сделать вложенный запрос или поставить оператор В()"? В данной статье я не дам вам исчерпывающих инструкций по чтению планов запроса. Но я постараюсь объяснить доходчиво - что это такое и с какой стороны к ним подойти.

04.07.2017    37585    0    Evil Beaver    58    

Счет-фактура с 01.07.2017 от 25.05.2017 №625 для ВСЕХ конфигураций 1С 8.х (БП 2.0, БП 2.0 КОРП, БАУ 2.0, БАУ 2.0 КОРП, КА 1.1, ПД 1.0, Розница 1.0, УНФ 1.3, УПП 1.3, УТ 11, УТ 10.3)

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ КА1 БП2.0 УТ10 Розница УПП1 УНФ БП3.0 БАУ УТ11 Россия БУ Абонемент ($m)

С июля 2017 года применяется новая печатная форма счет-фактуры в редакции Постановления Правительства РФ от 25.05.2017 № 625. В публикации собраны внешние печатные формы для всех популярных конфигураций 1С. Будет актуально для 90% организаций, которые не ведут учет по гос. контрактам, так как новое поле не заполняется, а вместо номера гос. контракта установлен прочерк по умолчанию.

1 стартмани

29.06.2017    43878    441    a.kapustin    43